2012年

11月

17日

[FAQ] Linux版インストールに失敗する

質問1

Field Reports Linux版のインストール時に以下のようなエラーが発生し,インストールできません。

 

$ sudo rpm -ivh reports-1.4-3.x86_64.rpm

エラー: Failed dependencies:

        libcurl.so.4()(64bit) is needed by reports-1.4-3.x86_64

回答1

Field Reportsはlibcurlに依存しています。

ご使用中のLinuxディストリビューションで利用できるパッケージ管理ツールを使ってlibcurlをインストールしてください。

 

# CentOSでの実行例:

$ sudo yum install curl-devel

 

自前でlibcurlをインストールした場合には,rpmコマンドに“--nodeps”オプションを付けて実行してください。

 

$ sudo rpm -ivh --nodeps reports-x.x-x.xxxx.rpm

質問2

Field Reportsのバージョンアップのためrpmコマンドを実行しましたが,インストールできません。

 

$ sudo rpm -ivh --nodeps reports-x.x-x.xxxx.rpm

Preparing... ########################################### [100%]

package reports-x.x-x is already installed

回答2

旧バージョンのField Reportsをアンインストールしてから新バージョンをインストールしてください。

 

$ sudo rpm -e reports